• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI seems to load twice

#1
[eluser]Y0shi[/eluser]
Hello there,

I've just written another function on my project which is coded with CI. My only one core class outputs something twice:

Core class header
Code:
class MY_Coresystem extends CI_Controller {

    function MY_Coresystem()
    {        
        parent::__construct();

Troublesome code
Code:
$output = $this->load->view('widgets/'.$element->sidebar_widget, '', TRUE);
    $this->template->write($element->sidebar_location, $output);

General controller header
Code:
class Article extends MY_Coresystem {

    function Article()
    {
        parent::MY_Coresystem();

Logging - all messages
Code:
DEBUG - 2011-04-18 22:03:03 --> Config Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Hooks Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Utf8 Class Initialized
DEBUG - 2011-04-18 22:03:03 --> UTF-8 Support Enabled
DEBUG - 2011-04-18 22:03:03 --> URI Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Router Class Initialized
DEBUG - 2011-04-18 22:03:03 --> No URI present. Default controller set.
DEBUG - 2011-04-18 22:03:03 --> Output Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Input Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Global POST and COOKIE data sanitized
DEBUG - 2011-04-18 22:03:03 --> Language Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Loader Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Helper loaded: cbasicfunctions_helper
DEBUG - 2011-04-18 22:03:03 --> Helper loaded: form_helper
DEBUG - 2011-04-18 22:03:03 --> Helper loaded: url_helper
DEBUG - 2011-04-18 22:03:03 --> Language file loaded: language/german/admin_lang.php
DEBUG - 2011-04-18 22:03:03 --> Language file loaded: language/german/controllers_lang.php
DEBUG - 2011-04-18 22:03:03 --> Language file loaded: language/german/global_lang.php
DEBUG - 2011-04-18 22:03:03 --> Database Driver Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Form Validation Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Session Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Helper loaded: string_helper
DEBUG - 2011-04-18 22:03:03 --> Session routines successfully run
DEBUG - 2011-04-18 22:03:03 --> Model Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Model Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Model Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Controller Class Initialized
DEBUG - 2011-04-18 22:03:03 --> Model Class Initialized
DEBUG - 2011-04-18 22:03:03 --> File loaded: application/views/widgets/userarea.php
DEBUG - 2011-04-18 22:03:03 --> Parser class already loaded. Second attempt ignored.
DEBUG - 2011-04-18 22:03:04 --> Model Class Initialized
DEBUG - 2011-04-18 22:03:04 --> Language file loaded: language/german/article_lang.php
DEBUG - 2011-04-18 22:03:04 --> File loaded: application/views/modules/article/showarticle.php
DEBUG - 2011-04-18 22:03:04 --> File loaded: application/views/system/system_adminaccess.php
ERROR - 2011-04-18 22:03:04 --> Severity: Notice  --> Undefined variable: kopfnavigation C:\XAMPP\htdocs\coreengine\trunk\application\views\style\frontend\main.php 44
DEBUG - 2011-04-18 22:03:04 --> File loaded: application/views/style/frontend/main.php
DEBUG - 2011-04-18 22:03:04 --> Final output sent to browser
DEBUG - 2011-04-18 22:03:04 --> Total execution time: 0.2104

So to summarize: When the page is being rendered, the content of widgets/widget.php is outputtet twice... Does anyone of you have general thoughts? Thanks in advance.

Regards

#2
[eluser]Y0shi[/eluser]
Quickly solved. Please delete *shame on me*


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.