• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Session issues CI 1.7.2

#1
[eluser]Unknown[/eluser]
Hi I'm finishing up a project and I'm suddenly having issues with CI. I'm running version 1.7.2 and I'm using the CI session class for setting and getting session data.

This happens in Firefox and IE. What's weirder is the application only works properly in Chrome. I have verified that this is happening in older builds of the application too which didn't have any issues previously.

The issue is when I try to access /controller/method it'll reload the current page and do nothing. Sometimes if I add /controller/method/ <-- forward slash, it will render the next page.

Here's my config:

Session

Code:
$config['sess_cookie_name']        = 'ciprojectname';
$config['sess_expiration']        = 7200;
$config['sess_encrypt_cookie']    = TRUE;
$config['sess_use_database']    = TRUE;
$config['sess_table_name']        = 'sessions';
$config['sess_match_ip']        = TRUE;
$config['sess_match_useragent']    = TRUE;
$config['sess_time_to_update']     = 900;

Cookies

Code:
$config['cookie_prefix']    = "";
$config['cookie_domain']    = "";
$config['cookie_path']        = "/";

I played with adding the cookie domain but the issue still happens. I've also read that it could be a time syncing issue with the server time but I've tried it on multiple servers. I guess the first thing to look at is why would CI would work in one browser and not others.


Any help would be greatly appreciated.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.