Welcome Guest, Not a member yet? Register   Sign In
Oracle INSERTs failing, but no errors

[eluser]Derek Allard[/eluser]
If you have something that you are confident is a bug, please make an entry in the bug tracker.

Already in there... since June.

[eluser]Derek Allard[/eluser]
OK, thanks. I don't have an oracle db - can you and or the others on this thread speak to the proposed solution in the bug report?

I'll try to collect the info from all the related forum threads and post a comprehensive fix in the report.

[eluser]Derek Allard[/eluser]
That would be awesome jonathan, and a big help. Thanks. Feel free to contact me personally (derek.allard at ellislab.com) afterwards and I'll move on it as I can.

[quote author="tonanbarbarian" date="1196754751"]try using
$result = $this->db->simple_query('...');

Will return a database result object where as simple_query will return a boolean result indicating the success or failure of the query[/quote]

This worked for me. I really appreciate you posting this solution since I have been trying to figure this out for a while now. I tried just about everything I could think of, but I didn't think of this. I am pretty relieved to have finally found an answer to my problem. Thank you very much.

Mmmmm I had the same trouble, so when you run php code, ensure you have no client open (like toad or sqldeveloper), because these tool open a transaction and when you run php code it fails without no errors. Make the next procedure to test your application:
1.- Close toad, sqldeveloper, isql, etc. (or if you are an advanced user, ensure that you have no transaccion open)
2.- Run your PHP code
3.- Open toad, sqldeveloper, isql, etc.
4.- See what happens
Well that was my problem, perhaps it works for you.

Theme © iAndrew 2016 - Forum software by © MyBB