Help with missing post data

#1
[eluser]Monotoba[/eluser]
I moved my sites to a new server. After the move I was able to see my web pages but when I attempted to log into the sites or submit ant forms, I found the site was unable to access the post data. I tried printing the $_POST and found an empty array. Now the really odd thing is that the server has a global install of phpmyadmin that works fine. Also, the first site installed under the Openpanel admin works just fine. But the sites installed under other users all fail to recieve post data. I have not tried to test GET data but that is my next step.

Anyone have any ideas on how I can debug this. I think it may be a permissions issue but not sure what is needed to access post data by the sites...

Update:
A test print of the $_GET results in: Array ( [REDIRECT_REQUEST_METHOD] => POST [REDIRECT_STATUS] => 404 [HTTP_HOST] => www.the-feed-bag.com [HTTP_CONNECTION] => keep-alive [CONTENT_LENGTH] => 52 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_ORIGIN] => http://www.the-feed-bag.com [HTTP_USER_AGENT] => Mozilla/5.0 (Windows NT 6.0) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7 [CONTENT_TYPE] => application/x-www-form-urlencoded [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 [HTTP_REFERER] => http://www.the-feed-bag.com/admin/login [HTTP_ACCEPT_ENCODING] => gzip,deflate,sdch [HTTP_ACCEPT_LANGUAGE] => en-US,en;q=0.8 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.3 [HTTP_COOKIE] => __utma=1.132837590.1319537727.1319537727.1319537727.1; __utmz=1.1319537727.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); ci_session=a:7:{s:10:"session_id";s:32:"fc886e725805816d571c693b497a7e88";s:10:"ip_address";s:14:"108.38.197.110";s:10:"user_agent";s:50:"Mozilla/5.0+(Windows+NT+6.0)+AppleWebKit/535.7+(KH";s:13:"last_activity";i:1325874001;s:4:"lang";s:2:"en";s:8:"last_uri";s:10:"avicon.ico";s:5:"page1";s:1:"1";}36a0568b96dcb40599185d889d1f784e [PATH] => /usr/local/bin:/usr/bin:/bin [SERVER_SIGNATURE] =>
Apache/2.2.14 (Ubuntu) Server at www.the-feed-bag.com Port 80
[SERVER_SOFTWARE] => Apache/2.2.14 (Ubuntu) [SERVER_NAME] => www.the-feed-bag.com [SERVER_ADDR] => 172.31.0.45 [SERVER_PORT] => 80 [REMOTE_ADDR] => 108.38.197.110 [DOCUMENT_ROOT] => /home/ChrisA/sites/www.the-feed-bag.com/public_html [SERVER_ADMIN] => webmaster@the-feed-bag.com [SCRIPT_FILENAME] => /home/ChrisA/sites/www.the-feed-bag.com/public_html/index.php [REMOTE_PORT] => 1024 [REDIRECT_URL] => /admin/login [GATEWAY_INTERFACE] => CGI/1.1 [SERVER_PROTOCOL] => HTTP/1.1 [REQUEST_METHOD] => GET [QUERY_STRING] => [REQUEST_URI] => /admin/login [SCRIPT_NAME] => /index.php [PHP_SELF] => /index.php [REQUEST_TIME] => 1325874714 )

Any ideas?

#2
[eluser]kevinAlbs[/eluser]
I'm having the same issue. I was working with my CI site on XAMPP on Windows 7, and once I moved it to the ubuntu server, none of the POST forms work. It acts as if no POST data was sent. And this isn't just an issue with the CI input class, because as you said, I printed the $_POST array and it was empty. And it couldn't have been an issue with the forms themselves, because I tried using CURL, and it still didn't receive the post data. I hope someone has an answer for this.

#3
[eluser]kanjimaster[/eluser]
Are you able to access the POST data via $this->input->post() ?

#4
[eluser]kevinAlbs[/eluser]
No, it acts as if there was no post data sent at all. I can't access it with $this->input->post or the $_POST array.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.