• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blank page after updating PHP and Apahe

#11
Where can I find out which CI version I'm using?
Reply

#12
It's defined in system/core/Codeigniter.php on the top as constant CI_VERSION;

Reply

#13
I'm using 2.2.0, I'll test now if it works in 3.x.
Reply

#14
In CI 3 it should work with PHP 5.6.
For CI 2.2.0 you need
a) downgrad to PHP 5.5
or
b) change the line 257 in /system/core/Common.php

PHP Code:
from 

$_config
[0] =& $config;
return 
$_config[0];

to

return $_config[0] =& $config

But if you can go with CI 3 you should ;o)

Reply

#15
I can definitely change to CI 3.
Thanks for that.

My site now works on all pages, except for one page that runs a db query.

It gives me this output:
Code:
Fatal error: Call to undefined function mysqli_init() in C:\websites\mvec.io2\system\database\drivers\mysqli\mysqli_driver.php on line 114
But PHPMyAdmin isn't working for me either.

So this now has to be a problem with loading extensions in PHP.

There goes the scope! lol
Thanks everyone I'll use CI 3 from now on, on all projects.
Reply

#16
Fixed the extension problem by changing the extension_dir PHP ini property.
Code:
extension_dir = "C:\PHP\ext\"

My site now works on CI 2 and CI 3. lol.

So all along this was not a problem with CI, apologies for that, and cheers for the support everyone.
Reply

#17
Have fun!Wink

Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.