404 problems

#1
[eluser]Kurai[/eluser]
Hi!
There seems to be a problem with 404 error pages on my codeigniter site. It seems not to get 404 error page correctly. When I try to access a nonexistent page, I get this message instead the default 404 CI page:

Quote:Not Found

The requested URL /wp-admin was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

What should the problem be? Thank you!

#2
[eluser]Craig A Rodway[/eluser]
Are you using mod_rewrite in .htaccess? If so could you post its contents as that's where the problem could be.

#3
[eluser]Sawariya[/eluser]
check your .htaccess file...
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^(index\.php|check_images|js|css)
RewriteRule ^(.*)$ index.php/$1 [L]

#4
[eluser]Kurai[/eluser]
Now that's funny. I'm not using mod_rewrite. I tried yours, and works perfectly. thanks.

#5
[eluser]John_Betong[/eluser]
[quote author="Kurai" date="1199373479"]Now that's funny. I'm not using mod_rewrite. I tried yours, and works perfectly. thanks.[/quote]
 
Hurray, eventually cleared a problem after a hard-disk crash.

The problem was that Wamp5 requires the #rem removing from the following default Apache config file:
 
httpd.conf
Code:
# LoadModule rewrite_module modules/mod_rewrite.so

Cheers,

John_Betong
 

#6
[eluser]Craig A Rodway[/eluser]
Just an FYI with WAMP: Instead of editing conf files, you can enable/disable Apache modules and PHP extensions using it's tray icon menus.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.