• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is sqlite support broken?

#1
[eluser]Starovich[/eluser]
I am trying to load up an SQLite database, but am seeing hard blank pages, even with maximum error reporting enabled, as soon as I load the db class I get a blank page back.

Has anyone gotten this kind of setup running? What are your settings?

Here is my database.php
Code:
$db['default']['hostname'] = '';
$db['default']['username'] = '';
$db['default']['password'] = '';
$db['default']['database'] = 'sqlite:/var/www/html/test/db/db.sqlite';
$db['default']['dbdriver'] = 'sqlite';
$db['default']['dbprefix'] = '';
$db['default']['pconnect'] = FALSE;
$db['default']['db_debug'] = TRUE;
$db['default']['cache_on'] = FALSE;
$db['default']['cachedir'] = '';
$db['default']['char_set'] = 'utf8';
$db['default']['dbcollat'] = 'utf8_general_ci';
$db['default']['swap_pre'] = '';
$db['default']['autoinit'] = TRUE;
$db['default']['stricton'] = FALSE;

CodeIgniter 2.1.0

#2
[eluser]Phil Sturgeon[/eluser]
Blank pages normally mean a fatal error is happening and error reporting is disabled. I'd check your PHP logs to see what is going on.

#3
[eluser]InsiteFX[/eluser]
Do a view source of the blank page and see if anything is in it like wierd characters etc.

Which will happen if your saving your files with the BOM!

#4
[eluser]Starovich[/eluser]
[quote author="Phil Sturgeon" date="1334788262"]Blank pages normally mean a fatal error is happening and error reporting is disabled. I'd check your PHP logs to see what is going on.[/quote]

Hi!

Here is my .htaccess for enabling error reporting:
Code:
php_flag display_errors on
php_flag display_startup_errors on
php_value error_reporting 2047

Also I have set error_reporting(E_ALL); in the controller where i attempt to load database.

Apache error log doesn't turn up anything, and access log says the empty requests were server with HTTP. status code 200.

Thanks for your help!

#5
[eluser]CroNiX[/eluser]
Set that in your index.php (in the appropriate ENVIRONMENT section) instead of your htaccess. The values in index.php are overriding your htaccess since it is changing them there and htaccess gets processed before index.php.

#6
[eluser]Starovich[/eluser]
[quote author="CroNiX" date="1334790550"]Set that in your index.php (in the appropriate ENVIRONMENT section) instead of your htaccess. The values in index.php are overriding your htaccess since it is changing them there and htaccess gets processed before index.php.[/quote]

It's already in development mode. Sad
Code:
define('ENVIRONMENT', 'development');

#7
[eluser]CroNiX[/eluser]
Great, but you might want to reread what I wrote.

#8
[eluser]Starovich[/eluser]
Did eventually figure this out by using PDO, check here for solution:
http://ellislab.com/forums/viewthread/219712/


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.