• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Getting Problem in Linking

#11
It's in http://localhost/CodeIgniter
Reply

#12
It sounds like his routes file is not setup correct.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#13
Everything is working fine except the issue I discussed here. What should I do now?
Reply

#14
Can you try to move your installation directly to your root localhost ?

Reply

#15
I moved it in root localhost, but still get the same issue.
Reply

#16
Thats realy strange. Can you post your /application/config/route.php content.

Reply

#17
Here is the code of route.php

$route['default_controller'] = 'pages/view';
$route['(:any)'] = 'pages/view/$1';


$route['news/(:any)'] = 'news/view/$1';
$route['news'] = 'news';
$route['(:any)'] = 'pages/view/$1';
$route['default_controller'] = 'pages/view';


$route['news/create'] = 'news/create';
$route['news/(:any)'] = 'news/view/$1';
$route['news'] = 'news';
$route['(:any)'] = 'pages/view/$1';
$route['default_controller'] = 'pages/view';
Reply

#18
Is it that link you try http://localhost/CodeIgniter/index.php/news/view/lorem-ipsum

then call it like

http://localhost/CodeIgniter/index.php/news/lorem-ipsum

Reply

#19
I am working with "http://localhost/CodeIgniter/index.php/news/lorem-ipsum"

but I already tried with "http://localhost/CodeIgniter/index.php/news/view/lorem-ipsum" as well.

both of them produce the same result (404 Error).
Reply

#20
Do you use the htaccess rewrites ?

What is in your $config['index_page'] inside /application/config/config.php

Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.