Welcome Guest, Not a member yet? Register   Sign In
Return URI Segment

Did you change your base_url in ./application/config/config.php ?

Yes before it was

$config['base_url'] = "http://www.baxobeat.com/";

and i changed it to

$config['base_url'] = "http://aapkapaper.com/demo/Baxobeat/";


Did you try all different URI protocols in application/config.php ?

$config['uri_protocol'] = 'AUTO';

segment 1 segment 2 etc;
$config[‘base_url’] = “http://aapkapaper.com/demo/Baxobeat/”;

$page_name =  $this->uri->segment(2);
$controller_name =  $this->uri->segment(1);

I would also check your ./application/config/routes.php file you may need to make changes in there also.

I tried by changing the URI Potocols but it didn't worked.

Can yu please suggest what changes i do in routes.php . In this page the following codes are seted.

$route['default_controller'] = "home";
$route['scaffolding_trigger'] = "";


Any help for this..........

I didn't get a solution for this. Can anyone help for this plz...........

Hi Rash,

on some webservers it can be a bit tricky to set up the
.htaccess in the right combination with uri_protocol in

Your welcome controller is working - I'm quite sure you
just have to configurate the .htaccess and uri_protocol.

Just a usefull snippet I found in these forums for config.php:

| Base Site URL
| URL to your CodeIgniter root. Typically this will be your base URL,
| WITH a trailing slash:
| http://example.com/
| If this is not set then CodeIgniter will guess the protocol, domain and
| path to your installation.
$config['base_url'] = isset($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on' ? 'https' : 'http';
$config['base_url'] .= '://'. $_SERVER['HTTP_HOST'];
$config['base_url'] .= isset($_SERVER['SERVER_PORT']) && $_SERVER['SERVER_PORT'] != '80' ? ( ':'.$_SERVER['SERVER_PORT'] ) : '';
$config['base_url'] .= str_replace(basename($_SERVER['SCRIPT_NAME']), '', $_SERVER['SCRIPT_NAME']);
$config['base_url'] = 'http://localhost/your_project/';

When uploading your project you don't have to think about setting the base_url

Try different .htaccess examples and try each possible uri_protocol when checking
a .htaccess.


Theme © iAndrew 2016 - Forum software by © MyBB