• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server/CodeIgniter crash for no apparent reason

#1
[eluser]Akaishen[/eluser]
Hello all,

I'm new to the forums and have been using CodeIgniter for about 4 months. Today, I've been doing a lot of work on my local server and came across a rather odd problem. I receive the following browser error:

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

This happens only on one controller that handles all my public pages. I've narrowed the problem to the controller I extend, which I've called Public_Controller, which is autoloaded using:

Code:
function __autoload($class)
{
if(strpos($class, 'CI_') !== 0)
{
  @include_once(APPPATH.'core/'.$class.EXT);
}
}

For three months, this has worked without any problems. Today, it just stopped working. There is nothing wrong with the file. The odd thing is, if I rename the file to Public_Controller2, it starts working again. I'm clueless.

If you have any thoughts or suggestions, please let me know. Your time and help is much appreciated!

~Akaishen

#2
[eluser]john_j[/eluser]
http://ellislab.com/forums/viewthread/154169/

#3
[eluser]Abel A.[/eluser]
sounds like a cache issue to me.

#4
[eluser]Akaishen[/eluser]
@John. Thanks for your reply. I don't believe I have an infinite loop.

@Abel. I don't use caching unless there's something happening automatically. It's not a browser cache as I have emptied my cache. Any tips on how I could debug it?

Thanks for the replies!

~Akaishen

#5
[eluser]Abel A.[/eluser]
I was more of the lines of server caching like APC. If nothing is wrong with the file, then there's something wrong with the server.

#6
[eluser]Akaishen[/eluser]
Thanks for your reply Abel. I use EasyPHP for my development environment. I'll look into any caching EasyPHP may add and see if that helps any. Thanks. Smile

#7
[eluser]InsiteFX[/eluser]
The message "Error 101 (net::ERR_CONNECTION_RESET): The connection was reset" is a general error from Windows.

The error indicates there is a software problem with your computer that could range from a malware infection to a corrupted web browser cache.

To fix the problem please try some of these troubleshooting steps :

1) Run an anti-virus app to see if you are infected.

2) You can download Microsofts stand alone offline defender.
Microsoft Offline Defender - Checks for root kits.

3) Try clearing out your browser cache.

#8
[eluser]Akaishen[/eluser]
Thanks for your reply InsiteFX.

I use Microsoft Security Essentials and although it shows my computer as being virus free, I had it do a full scan. It's updated and couldn't find any problems.

I cleared my browser cache and tried to run the page and it's still having the same problem. It tries to load for a bit then displays the same message: Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

I've enabled all log messages. The last log entry before the crash is Language Class Initialized. I'm going to read through all my code and make sure there's no infinite loops or anything. If you have any other thoughts, please let me know. Thanks for your time and help!

~Akaishen

#9
[eluser]InsiteFX[/eluser]
Download he Microsoft Offline Defender above and check your system, these root kits wil not be caught by anti-virus software.

It burns to a dvd and you boot from it.

It will catch what the anyi-virus software will not find.

#10
[eluser]Akaishen[/eluser]
Hey InsiteFX,

I didn't know that, thanks for clarifying. I did, however, just solve the problem. I used EasyPHP for my local development environment and just updated it. Now, everything works again. It's a good thing I'm bald, or I'd be pulling my hair out. Wink

I still don't understand how the server could work just fine for three months and then just stop. It could be a virus and I'll follow your recommendation and check with Microsoft Offline Defender.

It really saps any confidence I have for building a rock solid application for clients. I keep running into the oddest bugs and behaviors. Le sigh. Well, if the problem comes up again, I'll be sure to let you guys know. I'll also let you know if I am able to find a virus. Thanks for your help!

~Akaishen


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.