• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Code Igniter libraries and helpers not working on remote server

#1
[eluser]okemba[/eluser]
Hi Pals! I have just finished a portal built on codeigniter. visit www.jobconnect.info. I just realized that on the remote host, form validation and other libraries and helpers are not working but they work on my local WAMP. Any known issue of this kind. Please good people, I need assistance very urgently. It is a client project. Thanks

#2
[eluser]InsiteFX[/eluser]
Depending on the server make sure you uploded all files with lowercase filenames.

#3
[eluser]okemba[/eluser]
Everything works except the forms.Codeigniter Form validation does not work by a hair's breadth. Error log on apache server echoes a multitude of:

[Mon Aug 06 07:17:12 2012] [error] [client 41.155.92.83] File does not exist: /home/jobconne/public_html/advertiser, referer: http://jobconnect.info/advertiser/register_new

Strangely though, site works well on my WAMP localhost server but on a remote host, not breathing at all. I uploaded all files with a lowercase. yes i did. using Apache version 2.0.63. CI Profiler says no queries are run on form. Please visit site and see. Thanks

#4
[eluser]InsiteFX[/eluser]
For one jQuery needs to be loaded before any other js scripts.

Some of your links are not including the base path on js files etc;

Make sure that your base_url is set correct.

You are loading jquery at the top and bottom twice.

Do a view source and you will see the errors of things missing.

#5
[eluser]okemba[/eluser]
I implemented that but site is still not working. It looks like an apache configuration issue. Please somebody help me.

Thanks


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.