• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
segfault after upgrading 1.7.2 to 2.0 - Help!

#1
[eluser]lsalsich[/eluser]
All - I've been wrestling with this for a few days now. Searched everywhere and have tested various setting, etc. I'm out of ideas and could really use some suggestions from others, please.

I've upgraded my CI code from 1.7.2 to 2.0 following all the instructions. When I get to the point where I'm changing the first instance of
Code:
class Search extends CI_Controller{

function search() {
  parent::Controller();
  $this->load->model('msearch');
}
}

to:

Code:
class Search extends CI_Controller{

function __construct() {
  parent::__construct();
  $this->load->model('msearch');
}
}

Calling this controller causes the server to return a 324 error (blank page) and a seg fault in Apache. I've tried similar changes in other controllers with identical effects.

Any ideas what I'm doing wrong?

#2
[eluser]TWP Marketing[/eluser]
My first suspicion is that your CI installation is corrupted.
Try a reinstall of CI.

Also, unless you have some overriding need to use CI 2.0, I recommend upgrading to the latest stable release, which is 2.1.2. There were some bug fixes which you should avoid by the upgrade. Unless of course you meant the latest version by "version 2.0"

#3
[eluser]lsalsich[/eluser]
Thanks TWP. I hadn't thought of a corrupt CI install. That's worth looking at. I'll try that and post my results.

I guess I was going with 2.0 for now to see if I could get the change from 1.7.2 to 2.0 working and then I would move on to the latest version. Maybe that thinking doesn't make the most sense now that I reconsider.

#4
[eluser]TWP Marketing[/eluser]
So long as you watch all the items in the upgrade change log:
http://ellislab.com/codeigniter/user-gui...gelog.html
You should have no big problems.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.