• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I want my entire website works or open only with https

[eluser]Tejas D[/eluser]


I want my entire website(all pages) works or open only with https.
currently it perfectly works with http.

now, I want to work only with https.

what changes I need to do.I need detail steps how to use https with codeigniter.

Please suggest on this.

Assuming you haven't hardcoded any URL's in your application or in your application config, the quickest option is to use a rewrite rule that rewrites http to https.

See http://wiki.apache.org/httpd/RewriteHTTPToHTTPS

[eluser]Tejas D[/eluser]
Hello Sir,

Firstly Thank you.

Yes, I edited my .htaccess file and results in requesting the page through https.

But whether I need :

- to replace http with https in the code.
- to have ssl cert. and key.
- to edit httpd.conf to listen 443. etc

and what other changes I need to do.

Please will you see my post 'opera cache issue'.

Yes, you will not only need to add a ReWrite from *:80 to *:443, you will also need to modify your

- ports.conf
- httpd.conf
- vhost.conf
- ssl.cert, ssl.key, ssl.pem (or somehow get a ssl certificate, even self-signed works)

to make first of all your server listen on port 443 and then you can make changes to your site to use links pointing to https:// instead of http://

Should have added another assumption: you have setup your webserver for https... Wink

[eluser]Tejas D[/eluser]

Hi PhilTem,

The entire process is little bit lengthy.But I require https for opera, as it doesnot reloading
the page on clicking back button of browser.

somewhere I read problem can be solved by using https for opera.So, I am trying to use https.
But my entire website develop & work with http.

I want reload the page on clicking back button of the browser.

I used the below code As:

public function clear_cache(){
$this->output->set_header(“Cache-Control: no-store, no-cache, must-revalidate, no-transform, max-age=0, post-check=0, pre-check=0”);
$this->output->set_header(“Pragma: no-cache”);

This above code works fine with firefox,chrome.But doesnot work with opera.

Please can you give me solution on this.I want my website work also on opera.

Thanks in advance.

Did you try setting an expiration date in the past?
$this->output->set_header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");

[eluser]Tejas D[/eluser]
Hi... CroNIX

That didnot worked Sad

Now, I am trying to use load or unload events to achieve(opera issue to reload page on clicking back button of browser) that. Hope it will work but not sure.

If you have any solution, please share that.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.