• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI Forms not working in WampServer...

#1
[eluser]Unknown[/eluser]
I installed Wampserver per these directions:

http://www.adventuresindevelopment.com/2...n-windows/

CI and my development code is installed and runs, MySql DB access is working, etc. BUT, the CI Forms function does not seem to be working. Some of my project runs but the calls to the "forms" function don't return anything and I get no error log messages.

I AM loading the CI forms helper in my controller. All this code works on my live web site just not in the local Wampserver development environment that I am trying to setup.

I may have some"config" setting wrong but I cant figure out what that might be.

ARRGH, Help!

My Form View code:

<?php form_open('login/index/') ?>

<h1>LOCAL Login Form:</h1>

&lt;?php form_fieldset('Login Form', $attributes) ?&gt;

<div class="textfield">
&lt;?php form_label('username', 'user_name') ?&gt;
&lt;?php form_error('user_name') ?&gt;
&lt;?php form_input('user_name', set_value('user_name')) ?&gt;
</div>

<div class="textfield">
&lt;?php form_label('password', 'user_pass') ?&gt;
&lt;?php form_error('user_pass') ?&gt;
&lt;?php form_password('user_pass') ?&gt;
</div>
<br />
<div class="buttons">
&lt;?php form_submit('login', 'Login') ?&gt;
</div>

&lt;?php form_fieldset_close() ?&gt;

&lt;?php form_close(); ?&gt;

#2
[eluser]Unknown[/eluser]
WELL, I noticed that Short Tags was not set ON in my PHP.ini.

I set that ON and now things are working better.
Will post a followup if I can't get it all smoothed out from here...

Jean.

#3
[eluser]Bart v B[/eluser]
This problem has nothing to do with short tags.
You need to echo something. Wink

Code:
&lt;?php echo form_open('login/index/'); ?&gt;

<h1>LOCAL Login Form:</h1>

&lt;?php echo form_fieldset('Login Form', $attributes); ?&gt;

  <div class="textfield">
  &lt;?php echo form_label('username', 'user_name'); ?&gt;
  &lt;?php echo form_error('user_name'); ?&gt;
  &lt;?php echo form_input('user_name', set_value('user_name')); ?&gt;
  </div>
  
  <div class="textfield">
  &lt;?php echo form_label('password’, 'user_pass')' ?&gt;
  &lt;?php echo form_error('user_pass'); ?&gt;
  &lt;?php echo form_password('user_pass'); ?&gt;
  </div>


  <div class="buttons">
  &lt;?php echo form_submit('login', 'Login'); ?&gt;
  </div>
  
&lt;?php echo form_fieldset_close() ?&gt;

&lt;?php echo form_close(); ?&gt;


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.