• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI Google Maps Library - panoramioTag ```BIOSTALL (Solved

#1
[eluser]gazza7364[/eluser]
Hi

I've been playing around with CI Google Maps Library and I've got most things to work, but I'm having problems with panoramioTag. I've tried the following but no photos show.

Code:
function index() {


$data['results'] = $this->summits_model->get_summits();




$this->load->library('googlemaps');
//$config['minifyJS'] = TRUE;

$config['map_height'] = "800px";
$config['map_width'] = "600px";
$config['center'] = '54.43, -3.069';
$config['zoom'] = 'auto';
//$config['panoramio'] = TRUE;
$config['panoramioTag'] = 'Helvellyn';
$this->googlemaps->initialize($config);

$marker = array();

foreach ($data['results'] as $climbed):
{
$marker['title'] =  $climbed->peak_name;

$marker['position'] = $climbed->lat ."," . $climbed->long ;

$marker['infowindow_content'] = $climbed->peak_name . '<br>' . $climbed->ht_ft . "  " . $climbed->ht_m . "<br>" . $climbed->peak_area;




$this->googlemaps->add_marker($marker);
$this->googlemaps->add_marker($marker);
}
endforeach;

$data['map'] = $this->googlemaps->create_map();

$this->load->view('map', $data);


}
}

If I use
Code:
$config['panoramio'] = TRUE;
all the photos show, but I'm trying to restrict the photos, by showing only the photos within the panoramioTag tag.

Any ideas?


Solved

Needed to have
Code:
$config['panoramio'] = TRUE;
and $config['panoramioTag'] = 'Helvellyn'; loaded at same time, did try this at but didn't work. Alls working now.



#2
[eluser]BIOSTALL[/eluser]
Hi Gazza,

I've just seen this post and was just looking into it when I noticed that you had marked it as Solved.

Can I ask what the problem was and how you fixed it? Was it a problem with the library at all? I'm just wondering if there is anything I can add to the user guide that will prevent others running into problems.

Thanks,

BIOSTALL

#3
[eluser]gazza7364[/eluser]
HI BIOSTALL

I solved the problem by including:-

Code:
$config['panoramio'] = TRUE;
Code:
$config[‘panoramioTag’] = ‘Helvellyn’;

in the config together, when I was testing with I was using one or the other.

Code:
$config['panoramio'] = TRUE;
would show all pictures when used on its own, but if I used
Code:
[code$config[‘panoramioTag’] = ‘Helvellyn’;
on its own, no pictures would show. This wasn't explained in the documentation, so maybe it could be included.
When you look at it properly, its logical that
Code:
$config['panoramio'] = TRUE;
must be included when using
Code:
$config[‘panoramioTag’] = ‘Helvellyn’;
.
Just a late night, not seeing the wood for the trees.

Thanks for getting in touch and all the work on this library.

Gazza7364


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.