Is CI v2 inherently not meant to work with xdebug?

#1
[eluser]dhazer[/eluser]
I'm trying to do remote debugging on PhpStorm with xdebug.

I've been done extensive google searches on setting up xdebug with phpstorm and played with many possible settings and configurations.

I'm using phpstorm 5.0.2, Windows 7 professional, IIS 7.5, php 5.4 (php-5.4.4-nts-Win32-VC9-x86) and CodeIgniter 2.1.2

It seems to me that if I could get xdebug to read codeigniters files before executing, all would work out.

Has anyone figured this out?

Here's the error I get:

C:\php-5.4.4-nts-Win32-VC9-x86\php.exe -dxdebug.remote_enable=1 -dxdebug.remote_host=127.0.0.1 -dxdebug.remote_port=9000 -dxdebug.remote_mode=req C:\inetpub\wwwroot\application\controllers\inventory.php

Fatal error: Class 'CI_Controller' not found in C:\inetpub\wwwroot\application\controllers\inventory.php on line 5

Call Stack:
0.3011 181536 1. {main}() C:\inetpub\wwwroot\application\controllers\inventory.php:0


Process finished with exit code 255




#2
[eluser]vincej[/eluser]
HI - Like you I have just taken on PHPStorm with Codeigniter, and exactly the same as you I got the identical problem, however, with some help from some nice guys on the Storm site I got it solved in a few hours. I got Stom + Xdebug + CI working perfectly. Here is the post steam:


When I started: http://devnet.jetbrains.net/thread/438945?tstart=0

when it got fixed: http://devnet.jetbrains.net/message/5469444#5469444

BTW - I am moving off Dreamweaver, I have looked at Zend Studio, Netbeans and Aptana and Storm is the only IDE which handles both PHP *AND* HTML/CSS equally well - the others deal well with PHP only.

#3
[eluser]dhazer[/eluser]


@vincej, because of your post I got it figured out. Thanks again!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.