PHP 5.2.5

#1
[eluser]Ahmed Nuaman[/eluser]
Hey,

I've recently updated PHP to 5.2.5 from 5.1.2. However, I've had to revert because it seems that www.myurl.com/index.php/controller/function/var causes a CGI error.

PHP's running on IIS6 as a CGI extension.

Any ideas of what's causing this error?

Note: this error doesn't occur when it's page.php?var=value

#2
[eluser]Derek Jones[/eluser]
What's the error?

#3
[eluser]Ahmed Nuaman[/eluser]
All I get is a CGI error saying that the application (php-cgi.exe) sent the wrong HTTP headers.

#4
[eluser]Derek Jones[/eluser]
One of the pitfalls of running PHP under CGI is obfuscated errors. If it were me, I'd trace the app step by step until the error is triggered, with Routing being the most likely culprit.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.