• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fatal error: Class ‘CI_Driver_Library’ not found while trying to run on windows azure.

I am trying to get codeigniter working on azure websites. I am using the current developer build from github. (sqlsrv drivers work much better in the developer version with Azure sqlserver).

The problem I am having is when I call the sessions library it gives me this error.

Fatal error: Class ‘CI_Driver_Library’ not found in C:\VirtualDirectory0\site\wwwroot\system\libraries\Session\Session.php on line 53

The Driver.php file is in the libraries directory.

Anyone know what I might be doing wrong? Sessions seem to work ok with codeigniter 2.1.3 on Azure but then I have problems with some aspects of the sqlsrv database driver.

Thanks in advance…

For anyone having this trouble, I finally discovered the trouble.
sessions are now loaded as drivers. This recently became a requirement it seems.


needs to become:


Yeah, the Session library is a driver as of 3.0. 2.1.x and below can continue loading it as a library.


The topic was related to CI 2.1.3 , not 3.0

So that error should not happen in 2.1.3 correct?

[quote author="yabdab" date="1356108037"]Akon,

The topic was related to CI 2.1.3 , not 3.0

So that error should not happen in 2.1.3 correct?[/quote]
The topic is not related to 2.1.3 - he said he was using the "current developer build from github" which is 3.0.


Ah yes, my mistake. Sorry 'bout that.

I am getting the same error when trying to use version 2.1.3

I may just drop back down to 2.1.2 as that was working fine.

I am using codeigniter 3.0

I added

$autoload['drivers'] = array('session');

in config/autoload.php

It worked for me.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.