• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED]Unable to load helpers in module folder

#1
[eluser]msteudel[/eluser]
So I loaded up a project today that I was working on yesterday and it's suddenly throwing the following error:

Quote:An Error Was Encountered

Unable to load the requested file: helpers/account/ssl_helper.php

I'm sure I accidentally moved something around, can someone look at this file structure and let me know if this looks correct:
https://www.evernote.com/shard/s194/sh/9...e5a1ecc421

I checked folder permissions and file permissions, and they are all 755 (I'm on my macbook pro)

This is what my constructor looks like:

Code:
function __construct()
    {
        parent::__construct();

        $this->load->helper(array( 'language', 'url', 'form', 'account/ssl'));
        $this->load->library(array('account/authentication'));
        $this->load->model(array('account/account_model'));
        $this->lang->load(array('general'));
}

I even tried creating an empty helper in the account module folder and load that, but that didn't run.

I don't see any errors in the CI log or the PHP log.

This whole structure is based off of the A3M library.

Anyone run into this before?

MS

#2
[eluser]msteudel[/eluser]
I noticed that it is looking for the helper in the application/helper folder ... how do I get it to look at the modules folder?

#3
[eluser]msteudel[/eluser]
Figured out what it was. I installed Sparks via the one liner command, and it overwrote my Application/core/MY_loader.php which was using the HMVC loader. Here's something I found:

http://getsparks.org/set-up-mx

#4
[eluser]Jan_1[/eluser]
Thanks for sharing!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.