• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MY_Header.php

#1
[eluser]ironlung[/eluser]
Hi guys I'm getting this message in the error log

Code:
ERROR - 2013-03-03 17:50:53 --&gt; Severity: Warning  --&gt; include_once(application/core/MY_Header.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory /Users/peterclough/Intranet/codigos-de-descuento.es/wwwroot/application/config/config.php 344
ERROR - 2013-03-03 17:50:53 --&gt; Severity: Warning  --&gt; include_once() [<a href='function.include'>function.include</a>]: Failed opening 'application/core/MY_Header.php' for inclusion (include_path='.:/Applications/MAMP/bin/php/php5.3.6/lib/php') /Users/peterclough/Intranet/codigos-de-descuento.es/wwwroot/application/config/config.php 344


Here is the calling code
Code:
/*
| -------------------------------------------------------------------
|  Native Auto-load
| -------------------------------------------------------------------
|
| Nothing to do with cnfig/autoload.php, this allows PHP autoload to work
| for base controllers and some third-party libraries.
|
*/
function __autoload($class)
{
if(strpos($class, 'CI_') !== 0)
{
  @include_once( APPPATH . 'core/'. $class . EXT );
}
}



I have no .ext files, I have no file called MY_Header.*, I am at a loss.

Any help would be gratefully received, I recently upgraded from 2.0.3 to 2.1.3 and 2.0.3 was the last time I touched the code on the site.

#2
[eluser]TheFuzzy0ne[/eluser]
I'm at a bit of a loss myself. I'm not familiar with the inner-workings of Macs. The only thing I can suggest is to search the contents of all of the files in ./application for 'MY_Header', and see if anything comes up.

Failing that, search the CodeIgniter system directory too, but I doubt the problem will originate from there unless you've editted any of the files.

It may also help if you use [url="http://www.php.net/manual/en/function.debug-backtrace.php"]debug_backtrace()[/url] in your autoload function, and log the output for each call.

#3
[eluser]ironlung[/eluser]
Yeah I did that nothing, weird huh?
[quote author="TheFuzzy0ne" date="1362338347"]I'm at a bit of a loss myself. I'm not familiar with the inner-workings of Macs. The only thing I can suggest is to search the contents of all of the files in ./application for 'MY_Header', and see if anything comes up.[/quote]


No way would I edit anything in system.
[quote author="TheFuzzy0ne" date="1362338347"]Failing that, search the CodeIgniter system directory too, but I doubt the problem will originate from there unless you've editted any of the files.
[/quote]

That's great thanks I'll try that out...
[quote author="TheFuzzy0ne" date="1362338347"]
It may also help if you use [url="http://www.php.net/manual/en/function.debug-backtrace.php"]debug_backtrace()[/url] in your autoload function, and log the output for each call.[/quote]


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.