• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with CJAX

#21
[eluser]Ajaxboy[/eluser]
Yes, actually it is

$config->js_path what you need to defined/add in the config, as shown above.

Add the full path to where the js directory is, for example:

$config->js_path = ‘https://www.finaidtest.com/cjax/core/js/’;


Also make sure that your htaccess file is allowing the ajax.php file. The issue could be this alone and not the js path at all. So first you gotta make sure that the file is actually allowed to be viewed, before determining other issues.


Try the test:

your_site_url/ajax.php?test/test

You may also need to monitor the xhr request to see if there are any errors on the backend (use firebug for this, or chrome network activity) , it should always come back with a response, or an error, no way around that. Goal is to identify the error if any.

#22
[eluser]RaGe10940[/eluser]
I'm not using apache so .htaccess is out of the question, my rewrite rules are CI rules. I've changed the paths, names, and pretty much everything that you've told me to change. I can't keep wasting time on installation, I'm going to have to move on. Sorry.

#23
[eluser]Ajaxboy[/eluser]
Hello Rage10940,

Sorry for the delayed resposne, I have been busy at work. Would you be able to upload a test installation and allow me to test?, I haven't test in a none apache server, so I couldn't give you a diagnosis on it as it is, but I would be happy to look into it as soon as I get a chance, and figure out what the issue is.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.