Any problem with PHP 5.3.x version?

#1
[eluser]Unknown[/eluser]
Hi guys!!

Currently, I have a lot of projects written with CI last version 2.1.4 and my server run PHP 5.2.17 and all is ok.

Now, I need to upgrade to PHP 5.3.x and I wonder If i will be in troubles with CI.

CI is fully compatible with 5.3.x ??

I know, that with php 5.4 have some problems...

Thanks very much!! ;-)


#2
[eluser]noideawhattotypehere[/eluser]
Im running php 5.4.20 and no probs.

#3
[eluser]Unknown[/eluser]
Thanks noideawhattotypehere!!

Really?? what is your error_reporting() settings? do you use mysqli ??

system\database\drivers\mysqli\mysqli_driver.php

Line 318

Code:
elseif (function_exists('mysql_escape_string'))

http://php.net/manual/en/function.mysql-...string.php

"5.3.0 This function now throws an E_DEPRECATED notice."

My current developing machine run 5.4.0 and I must change mysql_escape_string to mysql_real_escape_string. or error_reporting(~E_DEPRECATED) to work.

This is not a big problem, but... really the framework is fully compatible with error_reporting(0) :cheese:

#4
[eluser]noideawhattotypehere[/eluser]
you mean mysql or mysqli? the second one is perfectly fine. im running in dev enviroment now so its error_reporting(E_ALL);

#5
[eluser]CroNiX[/eluser]
If that is the actual mysqli driver it looks like a bug, it should be using mysqli_real_escape_string (with the i in mysqli).


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.