Heater problem - can't find any white spaces

#1
[eluser]überfuzz[/eluser]
I'm tinkering with a site that's quite old by now. It's based on codeigniter 1.7. Now I get this message:
Quote:A PHP Error was encountered

Severity: Warning

Message: Cannot modify header information - headers already sent by (output started at xxxxxx/application/config/config.php:1)

Filename: libraries/Session.php

Line Number: 662

When I google this topic everyone point towards possible white spaces in the referred file. But I can't find any in my config-file. I'm pretty sure this was honky dory when I did the site. Any suggestions on what I should search for errors..?

Cheers!

#2
[eluser]Tpojka[/eluser]
I remember bugs related to byte ordering mark.
What W3C says with example.
I started from this page, but you could find more sources very easy.
Try to save (custom made) file(s) without bom.

#3
[eluser]überfuzz[/eluser]
[quote author="Tpojka" date="1385296087"]Try to save (custom made) file(s) without bom.[/quote]

What do you mean?

#4
[eluser]Tpojka[/eluser]
Find all files that are included in runtime (controller, model, custom made helper, custom made library...) and encode it to UTF-8 without BOM. In Notepad++ it is in Menu Encoding. Than save the file.

edit: or try it with config.php file first.

#5
[eluser]überfuzz[/eluser]
[quote author="Tpojka" date="1385297413"]...and encode it to UTF-8 without BOM.[/quote]
Sry for being such a noob about this, but whats a BOM?

Edit, by the way, is it possible to turn off warnings?

#6
[eluser]Tpojka[/eluser]
Just google for BOM. At wiki there is text too.
I am not an expert but witnessed saving file as UTF-8 without BOM could solve that problem.
I pointed how to set it in Notepad++, but every editor should have option for formating edited file(s).

For disabling warnings, you have to set code in index.php (the root one) with some of wanted levels.

#7
[eluser]überfuzz[/eluser]
Hmm.. It seems it was an upper/lower case letter issue. When I change the meta casting from: charset=utf-8 to charset=UTF-8 the warning vent away.

However, now some characters are �. An thought on that..?

#8
[eluser]überfuzz[/eluser]
No hold it...

I tried to duplicate the error, so I changed back and forth between lower and upper case. The issue is back, no matter how I set up the charset in the config-file.

#9
[eluser]Tpojka[/eluser]
I am assuming that you are talking about line in config.php:
Code:
$config['charset'] = 'UTF-8';

I was not talking about that in posts before, but I was talking about this:

1. download application/config/config.php
2. open it in Notepad++*
3. go to encoding menu
4. convert to UTF-8 without BOM
5. save file
6. upload and replace

*already said other rich editors have their options, but I can point on Notepad++ now

That is what I suggested in my first post too.
Why don't you try?


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.