• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Highslide with CI3

#11
What i found on your page is a js var

hs.graphicsDir = "highslide/graphics";

But the folder seams doesnt to exists on your server. Maybe this is the var for highslide where to search for graphics.

Reply

#12
This line is completely unnecessary and can cause issues:
RewriteCond $1 !^(index\.php|assets/img|assets/css|assets/js|assets/js/highslide|robots\.txt|favicon\.ico)

The following 2 lines (!-f, !=d) cover all of the above cases and any other REAL file/dir
Reply

#13
(04-22-2015, 02:58 PM)CroNiX Wrote: This line is completely unnecessary and can cause issues:
RewriteCond $1 !^(index\.php|assets/img|assets/css|assets/js|assets/js/highslide|robots\.txt|favicon\.ico)

The following 2 lines (!-f, !=d) cover all of the above cases and any other REAL file/dir

Hmm. I got this from one of my older projects which had similar problems when using php scripts outside CI. Never had any issues with this solution. This was taken from the Ellislab forums and just states that when files or folders are not found in one of the folders mentioned in the line, CI will not be used to serve a 404 page. That was exactly wat sackbut asked for. Maybe there is a better way...  Smile
Reply

#14
It means anytime you add an external dir to your app, like the highslide example, you have to remember to go back and update the line to exclude those dirs.

If you just use
Code:
RewriteEngine On
#If CI is in a subdir activate RewriteBase below
#RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]

That's all you need, because it does what the other line does except it works for ALL real files/dirs and not just the ones explicitly listed, so you don't need to remember to continuously update it as you add new dirs/files.
Reply

#15
Hello

OK - I have taken a day off from this problem to help clear my head - and learn enough about mod_rewrite to be able to understand the issues you guys are talking about. Then I'll try my highslide again, but in a simpler CI application, with just the one page, and if that works (which hopefully with all the good advice provided it will) I can move on.

I'll report back soon ( before end Saturday)
Reply

#16
(04-23-2015, 02:22 PM)sackbut Wrote: Hello

OK - I have taken a day off from this problem to help clear my head - and learn enough about mod_rewrite to be able to understand the issues you guys are talking about. Then I'll try my highslide again, but in a simpler CI application, with just the one page, and if that works (which hopefully with all the good advice provided it will) I can move on.

I'll report back soon ( before end Saturday)

It all works now - a clear head, good advice from the Highslide Forum and this Forum + a bit of revision on url re-writing and it's sorted ! see here

Thanks again guys
sackbut
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.