• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Devel Ver 3 worked - CI3 broken on live host

#1
Hi,
First, THANKS SO MUCH for taking over CI, and providing a path to the future with CI3 and maybe 4!!

I have a site that's been running quite happily with CI for years, first on CI2 and for the last 2 years with CI3 development version.  Now that CI3 is officially out I thought I'd go through the migration guide (2->3) and make sure that I caught all the changes.  With everything as up to date as I can make it --

On my XP machine with XAMPP everything works fine with the newest CI3 release.

When I try it on our live shared server I get the following error:

A PHP Error was encountered
Severity: Core Warning
Message: PHP Startup: ssh2: Unable to initialize module Module compiled with module API=20090626, debug=0, thread-safety=0 PHP compiled with module API=20090613 etc.

NOTE!!!  This is NOT an ssh2 problem as to my knowledge I'm not even using ssh.
If I go into php.ini and comment out the ssh2 line:
;extension=ssh2.so
it throws a different error:

A PHP Error was encountered
Severity: Core Warning
Message: PHP Startup: SourceGuardian: Unable to initialize module Module compiled... etc

Any insights will be appreciated
Reply

#2
This has nothing to do with CodeIgniter.
Reply

#3
(05-02-2015, 11:48 PM)ivantcholakov Wrote: This has nothing to do with CodeIgniter.
ivantcholakov, thanks for helpful response Big Grin

It does seem to have something to do with Codeigniter.  I switch from running CI development version 3 to release CI3 on a production server and it breaks.

Maybe if you could spare another sentence or two you could explain what it does have to do with.  Thanks
Reply

#4
You are using SourceGuardian on your production server. I don't think many people on this forum has experience with this tool, including me. But it looks like it compiles php code to bytecode and as you upgraded to CI3, you need to recompile it and that process fails due to improper configuration. Try to ditch SourceGuardian.
Reply

#5
@faradayent

I am not familiar with this tool too, the message looks like incompatibility of binary files. Maybe a upgrade in your server (Linux? Windows? Other?) lead to this.
Reply

#6
I've never heard of SourceGuardian before either.  Our host is Site5.com which is relatively big here in the states.  Don't know why they are using SourceGuardian.

I found several links kind of related:
https://forum.owncloud.org/viewtopic.php?f=4&t=10394

Since I first had the problem with ssh2, and then disabling that had it with SourceGuardian, I kind of suspect that if I could disable SourceGuardian (don't know how), that I would then show the same sort of error with something else.

Another curious thing is that the error only appears on php pages where I'm accessing the database, not on other php pages.

Strangely, none of this shows up in the site error_log.

I couldn't see what version of php CI3 requires now, but apparently Site5 is only running 5.2.17.

I appreciate ALL who have tried to help on this, but please don't waste your time on it past this point (unless something really hits you).  I'll see what I can figure out...
Reply

#7
(05-04-2015, 08:17 AM)faradayent Wrote: I couldn't see what version of php CI3 requires now, but apparently Site5 is only running 5.2.17.

For version 3, this says
Quote:CodeIgniter now requires PHP 5.2.4 and recommends PHP 5.4+ or newer to be used.
http://www.codeigniter.com/user_guide/ch...ht=version
Reply

#8
@faradayent

Delete the posted phpinfo file if you can.

If you can not upgrade the PHP engine, then make a test installation of one of my CI3-based developments: https://github.com/ivantcholakov/starter...-edition-3
Till the end of 2014 I tested it against PHP 5.2.0. There is a good chance it to work in your place. Even so, this is the bad choice.

The better choice is upgrading PHP.
Reply

#9
Turns out I had PHP5.2 set in the htaccess file from long ago.  Changed that to PHP5.3 and these errors went away.  PHP5.4 failed with a 500 error.  Don't know what's going on with that.


If any CI doc folks happen to see this it might be a good idea to put the PHP requirements somewhere in the Migration / Upgrading guide, and somewhere else where folks might see it.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.