Database connectio error

#1
[eluser]super3boy[/eluser]
I was following the 2nd video tutorial and then it gave me this error:

Quote:An Error Was Encountered

Unable to set client connection character set: utf8

I am kind of stuck. What do I do?

#2
[eluser]Derek Allard[/eluser]
Hey super3boy.

Welcome to CI! The video tutorial was done in an older version of codeigniter. Since then we've updated the way the database works, but the video hasn't been updated yet (apologies, I can see how this would be confusing). Do this, check out Upgrading from 1.5.3 to 1.5.4 and do steps 2 and 3, and also Upgrading from 1.5.4 to 1.6.0 and do step 4 (2 and 3 would also be a good idea).

That should get you up and rolling again.

#3
[eluser]super3boy[/eluser]
I am using the latest, 1.6.1, why do I need to upgrade?

#4
[eluser]Derek Allard[/eluser]
Oh I'm sorry super3boy. I misread your original post - and was thinking that you had... nevermind - it seems silly now that I'm typing it Wink

I assume you've got mysql? Which version?

#5
[eluser]super3boy[/eluser]
I am using MySQL4.0

#6
[eluser]Derek Allard[/eluser]
OK, then the problem is that MySQL (4.1+) is required, but if you want, you can get around that with instructions found here if you want to give it a run.

#7
[eluser]super3boy[/eluser]
Why thank you. It worked. Will MySQL 5 work fine also?

#8
[eluser]Derek Allard[/eluser]
My pleasure, and yes, you bet mysql 5 will work.

#9
[eluser]super3boy[/eluser]
Great! I suggest you post at link to that page on the video tutorial. That would might it much easier for people who are using a mysql version less than 4.1

Thanks for all the great help. I bet I will be back with more questions in a few hours or minutes. :-P

#10
[eluser]RickRobinson[/eluser]
Why am I having this problem if I'm using the pmachine hosting service?

- Rick


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.