• 2 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 3.0.6 Released

#11
Thank you all for the hard work. CI makes my life as a web developer much easier.
Reply

#12
Great!!! thanks for your hard work.
Q&A for Codeigniter
StartBBS--open-source, light weight forum software.
Best VPS:Digital Ocean
Reply

#13
(03-21-2016, 06:27 PM)CiAngle Wrote:
(03-21-2016, 03:50 PM)nplaviola Wrote: This feels like a silly question, but if I'm on 3.0.0 do I have to upgrade to each previous version, all the way up to 3.0.6? Or can I upgrade straight to 3.0.6?

Just copy system folder in 3.0.6 and paste to replace your system folder 3.0.0 ... upgraded  Angel

Sorry, didn't see your post! It's that easy then eh? I think I'll check the instructions for each upgrade in any case just to make sure, but thanks for letting me know.
Reply

#14
That was quite simple to upgrade. Thanks to the team who maintains and provides such great documentation for CI.
Reply

#15
The teams timely updates and attention to security prove that CodeIgniter is moving forward!

Thank you for your hard work and continued support.
Reply

#16
(03-21-2016, 10:06 AM)jlp Wrote: CodeIgniter 3.0.6 was released today, with some bug fixes and a minor feature.

Most importantly - it fixes a critical bug where a manually-crafted input could bypass Form Validation rules, so if you're using the Form Validation library, please update your application ASAP!

This is recommended for all users of version 3. Download v3.0.6 now, and we encourage you to read the changelog, and to check the directions for upgrading from a previous version.

Bug fixes address the Form Validation, Session and Migration libraries.
The minor feature is an enhancement to the Cache library.

What will be the alternative to prep_for_form? htmltoentities?
Reply

#17
After all these things with DIRECTORY_SEPARATOR in index.php,
the last line ends with:
'core/CodeIgniter.php'
! ? !

Shouldn't the last line be ?
require_once BASEPATH.'core' . DIRECTORY_SEPARATOR . 'CodeIgniter.php';
Reply

#18
(03-24-2016, 04:36 AM)ComputingFroggy Wrote: After all these things with DIRECTORY_SEPARATOR in index.php,
the last line ends with:
'core/CodeIgniter.php'
! ? !

Shouldn't the last line be ?
require_once BASEPATH.'core' . DIRECTORY_SEPARATOR . 'CodeIgniter.php';

Sure ... we were in a hurry to release a fix for a critical issue allowing anybody to bypass form validation, but your response is to rant about the tiniest possible inconsistency.

All these "things with DIRECTORY_SEPARATOR in index.php" affect constant values that you can use and therefore can affect your own logic; a hard-coded require_once() does not affect you.
Reply

#19
Just upgraded a few sites with 3.0.6 (from various previous versions, 3.0.1, 3.0.5 and 3.0.2 and followed all the docs) and every site is working perfectly following upgrades :-)

It also only took about two minutes per site as well.

Thank you for the quick fix to the unexpected critical issue, as always your hard work is very much appreciated.

Best wishes,

Paul.
Reply

#20
Thank you so much!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.