• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble getting started

#1
Bug 
I downloaded CI4, extracted the files and renamed the folder to ci4.
Then i added a virtual host:

Code:
<VirtualHost 127.0.0.1:80>
DocumentRoot "C:\Program Files (x86)\Ampps\www\ci4\public"
ServerName ci4.dev
</VirtualHost>

And "127.0.0.1  ci4.dev" to the Windows hosts file.

When i go to ci4.dev i get:
Quote:The ci4.dev page isn’t working

ci4.dev is currently unable to handle this request.

And the following in the error log:
Quote:[Tue Jun 28 07:13:08.222286 2016] [:error] [pid 4596:tid 1300] [client 127.0.0.1:64646] PHP Fatal error:  Uncaught Error: Class 'Config\\App' not found in C:\\Program Files (x86)\\Ampps\\www\\ci4\\public\\index.php:237\nStack trace:\n#0 {main}\n  thrown in C:\\Program Files (x86)\\Ampps\\www\\ci4\\public\\index.php on line 237

I also changed RewriteBase to "/ci4".

PHP version is 7.
Reply

#2
Hmm.. it looks like it should work. I know we caught something with Config\App not being found earlier in development on Windows but that was resolved. And you've made the document root to public so that's not the issue.

What is the HTTP status code being returned with the "ci4.dev is currently unable to handle this request." error?

Unfortunately, I just recently had to replace my hard drive, so I lost my Parallel's Window install, so it will be a couple of days until I can get a working Windows environment set back up.

Hopefully, someone else can help you out faster!
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#3
[Image: i4HGleJ.png]
Reply

#4
Have u restart the apache after creating vhost. Yesterday i tried ci4 first time end it was not working. But then i realised that i forgot to restart my Wamp after creating vhost. Silly mistake☺
          Heart  love codeigniter Heart
          Learning  best  practices
     Rate my post if you found it helpfull
Reply

#5
Yes, i did.
Reply

#6
One problem I see alot of here is that users place the servers under Program Files(x86) etc;

Most packages do not like this you should place the package in the C:\ root.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#7
I installed xampp and it works.

Code:
<VirtualHost 127.0.0.1:80>
DocumentRoot "C:\xampp\htdocs\ci4\public"
ServerName ci4.dev
</VirtualHost>
Reply

#8
Great! Glad you got it working!
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.