• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Codeigniter 4 Error on XAMPP

#1
Hi,

I am testing Codeigniter 4 on my windows 7 PC. I have downloaded the codeigniter 4 from github and copied all the files to my htdocs folder of my XAMPP installation on Windows 7. 

But I am getting an error


Quote:Fatal error: Default value for parameters with a class type hint can only be NULL in C:\xampp\htdocs\CodeIgniter4-develop\system\Config\DotEnv.php on line 121


Is there something I am missing?
Reply

#2
what php version?
Reply

#3
(07-22-2016, 08:26 AM)Avenirer Wrote: what php version?

Its PHP Version 5.5.9
Reply

#4
Definitely sounds like you're not running PHP7 here. Try running under PHP7 and that should go away.
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#5
(07-22-2016, 08:28 AM)kilishan Wrote: Definitely sounds like you're not running PHP7 here. Try running under PHP7 and that should go away.

Thank you so much? Can I get the link to Codeigniter 4 documentation.
Reply

#6
https://bcit-ci.github.io/CodeIgniter4/index.html
Reply

#7
XAMPP just released a version 7.0.8 for windows, but php.net has a newer security fix for php 7.0.9
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.