• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
form helper form_open() oddness

#1
Hello, I'm a newb.. going through the tutorial.

V. 3.0.6

I believe I've followed the tutorial correctly (copy / paste), but I'm getting a weird action with:

Code:
<?php echo form_open('news/create'); ?>



When I look at the source it shows:
Code:
<form action="<mydomain>/CI306/index.php/news/create" method="post" accept-charset="utf-8">

It does not list the protocol in the URI (http://), so my browser (firefox) treats it like an extension of the query string.. thus producing a URL of:

Code:
<mydomain>/CI306/index.php/<mydomain>/CI306/index.php/news/create

The docs show I am using form_open() correctly:
https://www.codeigniter.com/userguide3/h...-functions

Quote:Here’s a simple example:
echo form_open('email/send');

The above example would create a form that points to your base URL plus the “email/send” URI segments, like this:
<form method="post" accept-charset="utf-8" action="http://example.com/i

Any advice appreciated.  I can force the correct URL by adding the entire query string with the protocol, but that sure seems clunky.

Thx,
Donovan
Reply

#2
Did you set your ./application/config/config.php base_url[] ?
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#3
(08-02-2016, 03:06 AM)InsiteFX Wrote: Did you set your ./application/config/config.php base_url[] ?

Hi, thx for the reply. Yes. I was missing the protocol in the base URL. Adding it fixed the main issue.

Donovan
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.