• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HTML e-mail with attachment problem

#11
[eluser]sophistry[/eluser]
the user guide tells me that to get an html email to send i have to set mailtype config value to html.

did you do that? as rweston also suggests. it is not in your code.

http://ellislab.com/codeigniter/user-gui...email.html

#12
[eluser]stef25[/eluser]
that fixed it, thanks very much sophistry and rweston

#13
[eluser]rweston[/eluser]
no prob. stef.

sophistry, you didnt want me to paste all that in here did you? Smile
I do have it all though and will paste. Why cant debugging be easier? Smile

for my previous post, I had not copied the whole message, but i did later edit it.

They all come thru fine except for the html with the attachment. And i'm not quite sure how to send html without the plain text because doesnt the library automatically generate a text portion always?

Thanks for all the help,

#14
[eluser]sophistry[/eluser]
ok, back to debugging - i wish it were easier too! ;-)

does it change anything to send a different type of attachment?

also, did you try forcing the multipart class var to default to alternative instead of what it does now?
Code:
var    $multipart        = "mixed";    // "mixed" (in the body) or "related" (separate)

#15
[eluser]rweston[/eluser]
[quote author="sophistry" date="1204762897"]ok, back to debugging - i wish it were easier too! ;-)

does it change anything to send a different type of attachment?

also, did you try forcing the multipart class var to default to alternative instead of what it does now?
Code:
var    $multipart        = "mixed";    // "mixed" (in the body) or "related" (separate)
[/quote]

One word: "GRRRR".

I attempted what you suggested still no go. I stopped the hMail server, configured the IIS virtual smtp server and voila...

So it's gotta be something with hMail no? If not a bug, maybe just a configuration setting.

I think i was looking at the wrong suspect! Smile

#16
[eluser]sophistry[/eluser]
so, i guess voila means it's working with IIS virtual smtp? it was the hmail server all along?

#17
[eluser]rweston[/eluser]
>Sad [quote author="sophistry" date="1204765881"]so, i guess voila means it's working with IIS virtual smtp? it was the hmail server all along?[/quote]

Yeah, seems to have been. I really should have attempted that first. You suggested it in your first reply too!!!

I'm going to spend some time now trying to see what it might be in hMail and i'll just post an update.

There is an RFC compliance section under the SMTP portion of the server and there is an option allow incorrectly formatted line endings. With that option turned off, it doesnt accept the CI mail messages. With newline and crlf changed from "\n" to "\r\n" it then accepts the messages, but then i'm back to the original issue.

Initial thoughts, upgrade to latest stable hmail. I was using 4.4B270; went to 4.4.1B273. No change.
If anything, i'll send mail thru IIS Virtual SMPT and receive with hmail... >Sad

Thanks for the help again though sophistry.

#18
[eluser]rweston[/eluser]
and for the final reply, seems to have been neither CI nor hMail (good thing i didnt go to the hmail forms and played around a bit more... who knows what other talespin i would have put myself in).

the hMail server SMTP configuration has a section titled Delivery of e-mail which has 2 fields Host name and SMTP Relayer. I was relaying thru my ISP... I dont know why this caused a problem, but i'm not gonna try to figure that out... ISP SMTP server must me mucking with something in the message.

I set those 2 fields blank and everything is fine!

#19
[eluser]donpepito[/eluser]
If you use PHPMailer library (v2.3), don't forget to call one of these methods:
- IsSMTP()
- IsMail()
- IsSendmail()
- IsQmail()

I forgot to call IsSMTP() and html e-mails in Thunderbird and Outlook appeared as html code.

I hope this helps somebody.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.