• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED Unable to load the requested class: Globals

#1
I uploaded my script from my computer to a website and when I load my script I get the 

Quote:Unable to load the requested class: Globals

error.

The file I think being requested application/libraries/globals.php is lower case file name and inside config/autoload.php it says

Code:
$autoload['libraries'] = array('database', 'globals');


What is going on?
Reply

#2
Is this working on your local machine?

If so, this is usually because of a capitalisation problem.

Is your globals file called 'Globals'?
Is your class called 'Globals'?

Both need to be uppercase first letter.

Best wishes,

Paul
Reply

#3
It's fixed now. globals.php should have been Globals.php
Reply

#4
Please add SOLVED to the subject line
On the package it said needs Windows 7 or better. So I installed Linux.
Reply

#5
(07-03-2017, 07:58 AM)rtenny Wrote: Please add SOLVED to the subject line


The admins should add a mybb plugin to allow users to mark threads as solved.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.