• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 3.1.4-3.1.5 HTTP Session issue

#1
Hello Masters of CI.

TL;SR
(too long; should read) 

I have a small but interesting issue regardless of the versions of CI. 
Yesterday I downloaded v3.1.5, extracted and write a simple code ( https://www.tutorialspoint.com/codeignit...ncepts.htm ) then executed. What I paid attention that the browser still continued to wait for the code to be executed, as if the HTTP Session still continues, but the code is over and I see text that I need to see. I tried the same example with v3.1.4 but here everything worked OK!. The Question IS: Is this OK! or there is something wrong?

I am a beginner so I do not know how to go after the bug and hunt it.

Thank you in advance
Reply

#2
For one it depends on what type of sessions you are running which you did not mention.

Are they database, file etc;
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#3
No database, no file. Just this code

<?php
  class Test extends CI_Controller {  

     public function index() {
        echo "This is default function.";
     }
 
     public function hello() {
        echo "This is hello function.";
     }
  }
?>
What I mean by session: you enter a url and making an http request. Server (Apache 2.4  on windows machine in this case) responds to your request and closes the connection (https://developer.mozilla.org/en-US/docs...TP/Session).

THE PROBLEM: When I try the same code from v3.1.4 it is executed OK (HTTP/1.1 200 OK) but for v3.1.5 it continues to wait for the session to close (like circling sign where the favicon resides on the browser).

Note: I do not use the "?>" sign for my files (as described in https://codeigniter.com/user_guide/gener...e.html#id5 ).
Reply

#4
This is an HTTP Session, the wait can be a number of things like the server waiting for a response etc;

Use you browsers development tools to see whats going on most is F12 key
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#5
This could also be some external resource you are trying to load in 3.1.5.
Like some external JS, font files, css. The browser will wait for them to finish downloading even when the main request is already visiable on the screen.

In chrome tool use the "Network" tab to see t¡what the browser is waiting for.
On the package it said needs Windows 7 or better. So I installed Linux.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.