• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
do i need to load the model again and again?

#1
Is there any way to load a model once? 

I am experiencing with error:

Quote:Message: Undefined property: CI_Loader::$Users_model

when call for a view in my controllers.

loading the model solve it.

but do I need to load the model before any call to a view?

another error which is disappear 


Quote:Message: Call to a member function get_user_info() on null

I don't think its right way to load mode again and again.
Reply

#2
(10-12-2017, 07:55 PM)nadeem14375 Wrote: Is there any way to load a model once? 

I am experiencing with error:

Quote:Message: Undefined property: CI_Loader::$Users_model
when call for a view in my controllers.

loading the model solve it.

but do I need to load the model before any call to a view?

I don't think its right.

You only need to load a model if you are using it. If you use the model on every request you should auto-load the model.
Reply

#3
(10-12-2017, 08:01 PM)ChicagoPhil Wrote:
(10-12-2017, 07:55 PM)nadeem14375 Wrote: Is there any way to load a model once? 

I am experiencing with error:

Quote:Message: Undefined property: CI_Loader::$Users_model
when call for a view in my controllers.

loading the model solve it.

but do I need to load the model before any call to a view?

I don't think its right.

You only need to load a model if you are using it. If you use the model on every request you should auto-load the model.

you mean to add in autoload.php?
Reply

#4
I think you should load it in function __construct() then it should be fine. That is how I use
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.