• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Will CodeIgniter 4 be able to work on servers Using php =>5.6?

#1
As mentioned in CodeIgniter 4 User Guid, server requirements are:

PHP version 7.1 or newer is required, with the intl extension installed.

So, the point is, most hosting companies - including well known ones - doesn't yet set their PHP version to even 5.6, they still using PHP v5.4 OR PHP v5.5.

Will it be possible to use CI4 with these versions of PHP?

The best changes ever happens in CI4 is the using of namespaces with is not possible to be used in CI3. This will make the framework more fixable to create modules.
Reply

#2
(02-04-2018, 07:56 PM)moh.elogail Wrote: ... most hosting companies - including well known ones - doesn't yet set their PHP version to even 5.6, they still using PHP v5.4 OR PHP v5.5. ....

I don't know what hosting companies you are used to working with, but since these are all old versions of PHP, you should perhaps look for a new host. If you need a place to gather information about hosting, this forum is a good place to read: http://www.webhostingtalk.com/

If the problem is that your geographic location makes it hard to find a good host, you might consider starting your own hosting company. Might be a bit of money to be made.
Reply

#3
No, you will not be able to use CI4 with older versions of PHP.
You might consider a VPS hosting service, so that you are in control of the version of PHP used.
Reply

#4
Well I would change hosting providers then because I have WebHostingBuzz and they will install any
version of php I want on my server for me, I just have to tell it in the .htaccess file.
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.