• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Composer + CodeIgniter 4

#1
    Hello, half a year ago I somehow managed to install it, but now it does not work out, how can this be done?



  [InvalidArgumentException]
  Could not find package codeigniter4/framework with stability stable.


create-project [-s|--stability STABILITY] [--prefer-source] [--prefer-dist] [--repository REPOSITORY] [--repository-url REPOSITORY-URL] [--dev] [--no-dev] [--no-custom-installers] [--no-scripts] [--no-progress] [--no-secure-http] [--keep-vcs] [--no-install] [--ignore-platform-reqs] [--] [<package>] [<directory>] [<version>]
   
Reply

#2
There is no stability stable since there hasn't been a release.
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#3
how to download is not stable?
Reply

#4
It's in the CodeIgniter 4 User's Guide.

Code:
composer create-project codeigniter4/framework
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#5
Hello. I'm new here, sorry for bumping this thread again but I wrote the exact same question back in StackOverflow a few minutes ago and currently looking for an answer.

https://stackoverflow.com/questions/5088...ity-stable
Reply

#6
I am guessing that you didn't read the answer here - that there is no stable version of CodeIgniter 4?
Or perhaps you read the answer but wanted to hear it from someone else?
There is a suggestion in the stack overflow thread you made Undecided
Reply

#7
(06-16-2018, 01:28 PM)ciadmin Wrote: I am guessing that you didn't read the answer here - that there is no stable version of CodeIgniter 4?
Or perhaps you read the answer but wanted to hear it from someone else?
There is a suggestion in the stack overflow thread you made Undecided

Well, you don't have to be rude. I did read this thread. As I mentioned, I'm new here. You can call me a newbie as you wish but at least you could've replied by telling me to change the branch from 

Code:
codeigniter4/framework
into
Code:
codeigniter4/framework:dev-develop

and that will solve my problem instead of writing those 54 sarcastic words. The reason I choose CI4 over Laravel is due to its simplicity in documentation and easy to understand but I came across this confusion since I'm not quite familiar with composer (still learning). I'm not an A+ programmer but I just want to try things out to see if this framework suite me best and check if the community/support is great.
Thank you and no offense, admin.
Reply

#8
@rangka.kacang Glad you solved your issue Smile
Reply

#9
CodeIgniter 4 is a work in progress and has not been released for public use yet.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.