• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgrading CI to last version

#1
Hello everyone hopes you fine

I have a website using CI 3.1.5 and I need to upgrade to the last version is there more detailed to how can I do it? 

I'm an SYS admin, not a developer and the developer that make the website left the team
Reply

#2
You could use the following : https://www.codeigniter.com/userguide3/i...ading.html
So update 3.1.5 to 3.1.6 and then 3.1.6 to 3.1.7 (this is the official way).

However I think you could just update from 3.1.5 to 3.1.8 by replacing the system folder with the new one
Reply

#3
No because some of the updates make changes to the ./application folder.
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#4
(06-04-2018, 04:42 AM)InsiteFX Wrote: No because some of the updates make changes to the ./application folder.

what you mean by "no"? I shouldn't make the upgrade or what?
Reply

#5
(06-04-2018, 04:42 AM)InsiteFX Wrote: No because some of the updates make changes to the ./application folder and perhaps to index.php.

I believe there is only one change in the ./application/ folder associated with moving to 3.02

Otherwise, simply replacing ./system with the most recent version will work just fine. BUT, it would be wise to walk through each of the Upgrading From a Previous Version docs and make sure to take care of the very few items that require additional actions. All that said, some of the items should be checked by a developer.
Reply

#6
No not to just replace the system you also need to replace the index.php file etc;

You can watch the ./application folder for changes, I don't take chances so I
replace the whole framework I have a snippet app that I keep all my framework settings in.
What did you Try? What did you Get? What did you Expect?

Joined the CodeIgniter Community in 2009.          ( Skype: insitfx )
Reply

#7
(06-05-2018, 03:58 AM)InsiteFX Wrote: No not to just replace the system you also need to replace the index.php file etc;

You can watch the ./application folder for changes, I don't take chances so I
replace the whole framework I have a snippet app that I keep all my framework settings in.

Good grief man, the OP is only going from 3.1.5 to 3.1.7 !

The only reference in the instructions to index.php is the suggestion of temporarily putting a "site closed" static file in place while the upgrade happens. There is no reason to replace the CI index file.

There is no reason for stomp all over the application folder. The two "Upgrading from..." pages have only two steps the first step in each being

Quote:Replace all files and directories in your system/ directory.

There is nothing to indicate any files in or subordinate to /application need to be replaced. To my thinking, the chances something will go wrong are greater if you start messing with the /application files & folders. Remember, the OP is not a developer and has no idea what should or should not be in and under /application.
Reply

#8
upgardig Ci to last version to the 3.1.9 is the latest version of ci, you can upgrade your last version with that version.
Reply

#9
Replace all files and directories in your system/ directory.
If you have any custom developed files in these directories, please make copies of them first.
This config file has received some updates. Please copy it to application/config/mimes.php.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.