• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
flash data showing wrongly

#1
in my view
*********
 <div class="col-md-4">
                <?php
                    $this->load->helper('form');
                    $error = $this->session->flashdata('error');
                    if($error)
                    {
                ?>
                <div class="alert alert-danger alert-dismissable">
                    <button type="button" class="close" data-dismiss="alert" aria-hidden="true">×</button>
                    <?php echo $this->session->flashdata('error'); ?>                    
                </div>
                <?php } ?>
                <?php  
                    $success = $this->session->flashdata('success');
                    if($success)
                    {
                ?>
                <div class="alert alert-success alert-dismissable">
                    <button type="button" class="close" data-dismiss="alert" aria-hidden="true">×</button>
                    <?php echo $this->session->flashdata('success'); ?>
                </div>
                <?php } ?>
                
                <div class="row">
                    <div class="col-md-12">
                        <?php echo validation_errors('<div class="alert alert-danger alert-dismissable">', ' <button type="button" class="close" data-dismiss="alert" aria-hidden="true">×</button></div>'); ?>
                    </div>
                </div>


in controller
**********
$result= $this->User_model->studreginsert($insert);
         if($result == true)
                {
                    $this->session->set_flashdata('success', 'New student created successfully');
                }
                else
                {
                    $this->session->set_flashdata('error', 'student creation failed');
                }
                
                redirect('studreg');

values are inserted. but showing    $this->session->set_flashdata('error', 'student creation failed'); only . how to solve it?
Reply

#2
Please show the code for User_model->studreginsert. It appears it is not returning true. Hard to know why that might be without seeing the code.
Reply

#3
public function studreginsert($insert )
{

$this->db->insert_batch('pre_marks', $insert);
}
Reply

#4
Change:
Code:
$this->db->insert_batch('pre_marks', $insert);
Into:
Code:
return $this->db->insert_batch('pre_marks', $insert);
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.