• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
environment not supported

#1
Hello
i have moved the files and database from an existing working codeigniter website to another server. Updated the database configuration accordingly. But when i try to access the site, it says "Your environment does not support this system"

here is the link to the site http://172.245.190.247/

can any one tell me what could be the issue? 
thanks and regards
Ravi Kumar
Reply

#2
Are you using CodeIgniter 3? The error message text does not appear in the repo Undecided
This may not be a CodeIgniter issue, but rather a website configuration one.
Reply

#3
(07-14-2018, 11:30 PM)ciadmin Wrote: Are you using CodeIgniter 3? The error message text does not appear in the repo Undecided
This may not be a CodeIgniter issue, but rather a website configuration one.

no, its codeigniter 1.
Ok, i have tried it on both local host and a web server as well.. 
there is no error in apache log.
where else should i look?
Reply

#4
Hmmm - 1.0 predates my experience with CI by several years.
The oldest verison I have a copy of is 1.7.2, and the string "Your environment" is notfound in it.

I would suspect a PHP version incompatibility. CI1.0 was probably intended to run with PHP4, possibly PHP5. I would make sure that your new server has the same PHP version.

There could be some old-timers on the forum (even older than me) who might be able to shed some light on this Undecided
Reply

#5
ps - it doesn't sound like an error that would show up in any of the usual logs, but rather a message that some PHP script is creating before it dies "normally".

The script triggering this might even be in some custom code inside your app, and not in the CI system folder.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.