• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server upgraded to PHP 7.1

#1
Hi,

I am running a basic script on CI 2.2. Server owner notify me, that the server will get upgraded from php 5.6 to 7.1 and older version will not be supported anymore. As I understand I should upgrade CI to 3.0, but looks quite tricky and not straightforward at all.
Is there anything else i can do?
Reply

#2
@Gilbert,

If you are able to create a test server environment to test your upgrade to CI 3.x and PHP 7.1

That is the only thing that I could think of.

There is documentation to assist you (assuming no changes were made to the core files): https://www.codeigniter.com/userguide3/i...ading.html
Reply

#3
I use Virtual HOSTS to do my local development running PHP 7.2.9

My live server allows me to select what version of PHP I want to run with a DropDown
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#4
SO It's not even sure that CI 3.x will work on PHP 7.1?
Reply

#5
CI 3.x works just fine on PHP7.1 ... we have been using that since it came out.
Reply

#6
Like I said in my post I'm running PHP 7.2.9
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.