• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setting environment in .env - can't get it working

#1
I downloaded a fresh copy of CI4 from the development branch. The default welcome page displays environment -

Code:
Page rendered in {elapsed_time} seconds. Environment: <?= ENVIRONMENT ?>

I, then, created a copy of "env" to ".env" and only added this line

CI_ENVIRONMENT = production

I still see environment as "development"

I can't find any settings which i can change in config/app.php

What am I doing wrong?
Reply

#2
Could be that CI_ENVIRONMENT was set (by .htaccess?) before the .env is processed. Per the documentation "If the variable exists in the environment already, it will NOT be overwritten."

I've no idea if the documentation is accurate - it is still in development too.
Reply

#3
(09-19-2018, 08:56 AM)dave friend Wrote: Could be that CI_ENVIRONMENT was set (by .htaccess?) before the .env is processed. Per the documentation "If the variable exists in the environment already, it will NOT be overwritten."

I've no idea if the documentation is accurate - it is still in development too.

Yes you were right - it was the .htaccess indeed. Thanks for your help.
Reply

#4
CI_ENVIRONMENT = development

At latest build it is working fine..
Best VPS Hosting : Digital Ocean
Reply

#5
(09-20-2018, 10:53 PM)sv3tli0 Wrote: CI_ENVIRONMENT = development

At latest build it is working fine..

Yes it is working for me too. But if you intend to switch/control environment using .env files, you must disable it first in the .htaccess file.

My issue above was that I didn't realise it was there in the .htaccess so perhaps it needs to be mentioned in the documentation more clearly on this page https://bcit-ci.github.io/CodeIgniter4/g...ments.html
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.