• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to remove index.php on IIS 10

#11
(10-08-2018, 02:17 PM)jreklund Wrote: appendQueryString="true" in my web.config should solve that one.

I made the changes to the web.config file and set $config['index_page'] = '', and unfortunately, I still can't load any page except the default controller in the routes file. I get the error "No input file specified." I'm no IIS expert, but I'm thinking that there's some configuration I need to change on IIS.
Reply

#12
Try this:
https://serverfault.com/questions/883420...-specified
Reply

#13
That didn't work either; however, I did finally find the problem! In my php.ini file, I had set cgi.fix_pathinfo=0 based on a recommendation for installing PHP on IIS...after changing it back to cgi.fix.pathing=1, everything started working again! Thanks for your help.
Reply

#14
If that's the case you are reading old resources and need to check other settings as well. Here are one for IIS 8+.
https://docs.microsoft.com/en-us/iis/app...p-settings
Reply

#15
(10-09-2018, 09:21 AM)jreklund Wrote: If that's the case you are reading old resources and need to check other settings as well. Here are one for IIS 8+.
https://docs.microsoft.com/en-us/iis/app...p-settings

I'll check it out, much appreciated.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.