help

#1
[eluser]bertico[/eluser]
hello, I learning to use codeigniter and I'm new yet, Sorry my English, I'm learning too. If you can help me I will thank you. The problem is that I need to work with a LDAP server but don't let me to connect it.
the error is:
Fatal error: Call to undefined function ldap_connect()
My question is : What configuration I need to change to use that?.
thanks .

#2
[eluser]Seppo[/eluser]
You need to install the ldap extension. Do you have access to your server? Which OS is your server running?

#3
[eluser]bertico[/eluser]
thanks for your answer. I already installed the ldap extension. I restarted my server apache too.
the error is the same:
Fatal error: Call to undefined function ldap_connect() in C:\AppServ\www\Caracterizacion\system\application\libraries\Ldap.php on line 21
what also I need to do?
thanks and remember , sorry my english

#4
[eluser]Seppo[/eluser]
That error probably means that the extension is not properly installed... Run this code
Code:
echo extension_loaded('ldap') ? 'Loaded =)' : 'NOT Loaded =('
to check that.

By the way, your native language is spanish?

#5
[eluser]bertico[/eluser]
thanks again for your answer
it returns me: NOT Loaded =(
What means that ? and what I need to do?

Y si mi idioma nativo es el español..

#6
[eluser]Seppo[/eluser]
That means you have not loaded the ldap extension...
What you have to do depends on your install... If you are using windows the first thing is going to php.ini and look for a line like this
Quote:;extension=php_ldap.dll

In linux you should have it .so instead

El mío también =)

#7
[eluser]bertico[/eluser]
ok , I already do that , but the problem not change, I ran the code that you gave me previously and it returns me the same : NOT Loaded =( .
yo soy cubano..

#8
[eluser]Seppo[/eluser]
Well... that and restarting the server should do it...
Check your phpinfo to see if you are not editing a php.ini file different from the one loaded.

Yo argentino

#9
[eluser]section31[/eluser]
Please title your threads correctly.

#10
[eluser]bertico[/eluser]
ok , I did all that you told me. The php.ini file is OK, but in the apache's loaded modules in my phpinfo , mod_authnz_ldap doesn't appear. it is not this module necessary? How can install it?


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.