HELP!!!!GET is not working!!!

#11
[eluser]John Fuller[/eluser]
Well, either way I do agree you should have the option to use GET if you like. You might post something in the feature request forum.

#12
[eluser]wiredesignz[/eluser]
$_GET is already available in CI. Just enable it and away you go. Pokerking has a server or setup issue preventing its use.

#13
[eluser]xwero[/eluser]
The only problem with using $_GET is you can't use it with only one key-value pair if the uri_protocol is set to AUTO. Maybe AUTO shouldn't be the default setting for the uri_protocol?

#14
[eluser]wiredesignz[/eluser]
Thanks for that xwero, I use PATH_INFO mostly, do you know if there is a limit with this?

#15
[eluser]xwero[/eluser]
With path_info CI leaves $_GET as it is.

router.php _get_uri_string not AUTO setting snippet
Code:
$uri = strtoupper($this->config->item('uri_protocol'));
            
if ($uri == 'REQUEST_URI')
{
    return $this->_parse_request_uri();
}
            
return (isset($_SERVER[$uri])) ? $_SERVER[$uri] : @getenv($uri);

#16
[eluser]wiredesignz[/eluser]
Thanks man Wink

#17
[eluser]John Fuller[/eluser]
[quote author="wiredesignz" date="1207575315"]$_GET is already available in CI. Just enable it and away you go. Pokerking has a server or setup issue preventing its use.[/quote]

Well sure, GET comes with the environment. But he brings up good point. Ellislab is sort of forcing the decision to blast it by default. Maybe it should not be that way (yet another place to go to make a configuration change if you want access to GET in CI.)

Personally, I prefer using segments and obviously Ellislab prefers it. I have never used GET with CodeIgniter. But, backtracking on my first post, maybe it shouldn't be a restriction out of the box.

#18
[eluser]Lima[/eluser]
It seem like KeyStroke's problem
Please see my post on http://ellislab.com/forums/viewthread/75480/P0/
and it just another option. hope it can help.

I LOVE CI :-*

#19
[eluser]pokerking[/eluser]
still not solved. so if anyone did get without index.php . let me know. I need to match the config .htaccess and anything else.

#20
[eluser]Unknown[/eluser]
Dude, try this

http://ellislab.com/forums/viewthread/56389/#277621

from http://codeigniter.com/wiki/QUERY_STRING_GET/


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.