• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Whoops! Asking for help

#1
Hi CI guys

Im embarrassed to be asking you all this. 

I am running CI on IIS. I have an install of the CI Alpha 5 and an install of the most current Beta 3.

The Alpha runs ok. The beta only gives me the Whoops error message "We seem to have hit a snag. Please try again later..."

The only error message I see is logged in the Log file in Inetpub. Its a 500 server error. Nothing is getting written to the log files in the WRITEPATH

The installs are configured exactly the same in IIS, with a virtual host pointing to the public folder. 

I've upgraded for now to PHP7.3 and un-commented the INTL and CURL libraries (assuming that is what is meant in the server requirements page.)

SO there is something I'm not seeing. I'm missing a setting and hoping someone can point me in the right direction. Thanks for anyone who can help. 

Kil, if your reading this, I still plan on testing the cURL fix you implemented. 

Thanks all.
Reply

#2
Turn debug on and you'll get something more informative as to what is wrong. To turn debug on set your environment to "development" in the .env file or the .htaccess file.
Simpler is always better
Reply

#3
(05-16-2019, 05:06 PM)donpwinston Wrote: Turn debug on and you'll get something more informative as to what is wrong. To turn debug on set your environment to "development" in the .env file or the .htaccess file.

Dev is set in the ENV file. Correct me if Im wrong but IIS doesn't use the .htaccess?

This is the only error logging I see.

#Software: Microsoft Internet Information Services 10.0
#Version: 1.0
#Date: 2019-05-17 15:18:55
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) cs(Referer) sc-status sc-substatus sc-win32-status time-taken
2019-05-17 15:18:55 ::1 GET /beta/index.php - 80 - ::1 Mozilla/5.0+(Windows+NT+10.0;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 500 0 0 799
2019-05-17 15:19:08 ::1 GET /beta/index.php - 80 - ::1 Mozilla/5.0+(Windows+NT+10.0;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 500 0 0 34
2019-05-17 15:21:20 ::1 GET /beta/index.php - 80 - ::1 Mozilla/5.0+(Windows+NT+10.0;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 500 0 0 83

Thoughts?
It seems I am getting the production error page leading me to wonder if I have set the environment to development correctly.
Reply

#4
OK SO....
Using IIS I think doesn't refer to either the ENV or .htaccess files. I added the following line to index.php to enable debugging

$_SERVER['CI_ENVIRONMENT'] = 'development';

Just wondering if another way to set the env for people trying to use IIS has ever been established?

OK so the debugging window looks great. First time I've seen it.

Debug window has a stack trace. Error message in general is "Cache unable to write to C:\inetpub\wwwroot\beta\writable\cache/ "

Might be a permissions issue? Sticking with this. Hoping for an assist.
Reply

#5
Ok I figured out the Caching issue and it was permissions related so no worries.

I'd still like to hear from anyone on setting environment settings that work in IIS. The SetEnv in the htAccess and CI_ENVIRONMENT in the env file doesn't work as I dont believe IIS used them.

That's about it. I'm up and running with Beta 3. Still have $_SERVER['CI_ENVIRONMENT'] = 'development'; in my index.php though .

Thanks all for reading this.
Reply

#6
(05-17-2019, 03:22 PM)mightyted Wrote: Ok I figured out the Caching issue and it was permissions related so no worries.

I'd still like to hear from anyone on setting environment settings that work in IIS. The SetEnv in the htAccess and CI_ENVIRONMENT in the env file doesn't work as I dont believe IIS used them.

That's about it. I'm up and running with Beta 3. Still have $_SERVER['CI_ENVIRONMENT'] = 'development'; in my index.php though .

Thanks all for reading this.

You have to rename env to .env. Your right IIS doesn't use .htaccess, Apache does. Renaming env to .env should work.
Simpler is always better
Reply

#7
Thank for that Winston! I had no idea.

Here is some additional instruction for anyone else who has this issue and wants to use the windows GUI to rename the file.

https://superuser.com/questions/64471/cr...in-windows
Reply

#8
You're running in the production environment and need to change it to a Development or Testing environment to see the error messages within the browser MyLowesLife

There are a few ways to do this, but adding:

SetEnv CI_ENVIRONMENT development
To the Apache httpd.config file is what worked for me.

_t
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.