Welcome Guest, Not a member yet? Register   Sign In
Spark Serve Options
#1

Hi All,

I've installed CI4 appstarter using composer and want to run on port 80.

I ran php spark serve and noticed that any --options were being ignored.

Looking at Serve.php and CLI.php can someone explain how I should set required options?


All the best.
Reply
#2

It's in the CodeIgniter 4 User Guide.

Code:
php spark serve --port=8081

Change port to your port.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply
#3

It's in the CodeIgniter 4 User Guide.

Code:
php spark serve --port=8081

Change port to your port=80
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply
#4

(06-09-2019, 03:10 AM)InsiteFX Wrote: It's in the CodeIgniter 4 User Guide.

Code:
php spark serve --port=8081

Change port to your port=80

Sorry for delay in replying (thought I'd subscribed).

I know that you can specify the port, what I meant to say was that I think it is being ignored.
Reply
#5

I stumbled over the same issue. The solution is quite simple: Remove the "=". So if anyone else has this problem, the solution is:

Code:
php spark --port 80

Same with any other option. At least in Windows it's working this way. Not sure yet about Linux.
Reply
#6

(10-18-2019, 08:26 AM)BlindPenguin Wrote: I stumbled over the same issue. The solution is quite simple: Remove the "=". So if anyone else has this problem, the solution is:

Code:
php spark --port 80

Same with any other option. At least in Windows it's working this way. Not sure yet about Linux.
Yes its working also in Linux, no = between!
php spark serve --port 8083
Reply




Theme © iAndrew 2016 - Forum software by © MyBB