• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to have more detailed error

#1
In CI3 We had lines or error

now with CI4 I only have Whoops!

We seem to have hit a snag. Please try again later...

And I know something is wrong but I have no idea where to search.

How to have like CI3  error lines
Reply

#2
https://codeigniter4.github.io/userguide...hoops-page
Reply

#3
thank you for the link. I read it and understand

You can see the error in the debug toolbar display by setting your environment to “development” (in .env), and reloading the page.

What is the debut toolbar? I don't have that. How to configure the .env?
Reply

#4
https://codeigniter4.github.io/userguide...t-constant
Reply

#5
Thank you
I try to put

SetEnv CI_ENVIRONMENT development in the .htaccess
SetEnv CI_ENVIRONMENT development
But no change. It is the same


CI_ENVIRONMENT = developpement in the .env file and I got that message


The application environment is not set correctly.
Reply

#6
You have spelled “development” two different ways in your post. Make sure you have it correct in your .env file - also make sure you have the period “.” in front of the file (the version that ships is simply “env”). If those are set correctly and you still get the error make sure you have removed all the other methods of setting it (like .htaccess) and are using an updated copy of the framework.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.