• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
spark Command "list" not found. ** RESOLVED - CONFIG ERROR **

#1
I was trying to reload a migration for testing via spark and received the following error trying to execute spark:


Command "list" not found.


I moved down to RC4 from RC3 when 4.0.1 broke my dev site.
Reply

#2
Have you used 4.0.2 yet? That fixed a number of issues related to fragmented releases
Reply

#3
(03-01-2020, 08:46 AM)MGatner Wrote: Have you used 4.0.2 yet? That fixed a number of issues related to fragmented releases

Yes - I did additional testing and reported back on this thread: https://forum.codeigniter.com/thread-75633.html as it is the same problem. Appears to be a problem at minimum with the appstarter project.
Reply

#4
Just want to bump this topic again. I have still been unable to resolve this issue. I suspected it was at first something to do with a path issue, but I replaced the paths files and still have same error. I cannot simply restart my repo as months of work has gone into it. What else might cause the spark tool not to find the "help" command. My gut says this is a path issue, but I also have filters that run.

One thing I did also notice is that when I ran it without a .env file I got different errors regarding my missing redis information (we log to redis before writing to a database for further inspection). When I put the .env file it continues with no error.

Error Message:
CodeIgniter CLI Tool - Version 4.0.2 - Server-Time: 2020-04-06 22:00:19pm

Command "help" not found.
Reply

#5
I finally tracked down this problem to a bad entry in my app/Config/Autoload.php file. I had added a PSR-4 mapping for my SAML (SimpleSAML) that pointed to a shared autoload.php file instead of an actual path. I have other namespaces loaded here, not sure why this did not trigger some sort of error, but seems to be working now that it is fixed.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.