• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The requested URL was not found on this server. Error

#1
Hello,

I just joined you. We need to make a website with codeigniter 3 for my school project. I created my project. I created a virtual server using AppServ. While trying to create VirtualHost, apache24 stopped running, I tried again, but it still didn't. I also copied the content in AppServ / www and put it in another folder. I completely deleted AppServ. I reloaded. I pasted the folder contents in www. I have not changed any settings related to Codeigniter. Although the default controller site works when loading first, the links do not work. Since AppServ and apache broke down, I was able to access the controller and function by typing home / index since the url definition was done without any problems, but now I get the requested URL was not found on this server error. .htacces and base url are defined. I can't find the error please help

My .htaccess file from directory root

[Image: 1.jpg]

My home view.  (It works while first loading. But when I click on the homepage (or on a different link) I get the same error again.)

[Image: 4.jpg]

Error page when i click some link in homepage. url path is correct but controller and function not working

[Image: 2.jpg]

My base url settings

[Image: 3.jpg]

Routes

[Image: 5.jpg]

Thank you for your answers. My english is not so good- im sorry for that.
Reply

#2
Hi, can you post your virtual host settings in AppServ?

It dosen't look that you have created one, you just loaded localhost, that's the default one.
Reply

#3
(06-26-2020, 12:04 AM)jreklund Wrote: Hi, can you post your virtual host settings in AppServ?

It dosen't look that you have created one, you just loaded localhost, that's the default one.
Hi, i created one before but when i got the error i got the normal settings. I don't want a virtual host right now. I just want it to work normally. But i can't find the problem.

[Image: 6.jpg]
[Image: 7.jpg]
[Image: 8.jpg]

I changed these settings before I got the error. then I returned to normal settings. but Could there be a version mismatch? appserv uses php7. I'm using codeigniter 3. But if there was a version mismatch, I would get this error before. There was no such error before changing the virtual host settings.
Reply

#4
I found the problem. not loading the rewrite module.

Load rewrite module. conf directory // AppServ/apache24/conf/httpd.conf 

[Image: 12.jpg]

And write this text. When I did these, the error disappeared

[Image: 13.jpg]

If there are other friends who have received this error, they can try this solution. Thank you.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.