• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
failing to open autoload

#1
I am getting this error when i try running. The file where it occurs, MyReport.php is located in: /app/assets/MyReports.php.
Seems like a weird place to keep code but that is what the koolreport "docs" told me to do. 


A PHP Error was encountered
Severity: Compile Error
Message: require(): Failed opening required '/app/application/libraries/koolreport/core/autoload.php' (include_path='.:/opt/bitnami/php/lib/php')
Filename: assets/MyReport.php
Line Number: 3
Backtrace:



Here is the MyReport.php:

<?php
//MyReport.php
require APPPATH."libraries/koolreport/core/autoload.php";
class MyReport extends \koolreport\KoolReport
{
/*  use \koolreport\clients\Bootstrap;*/
  public function settings()
    {
        return array(

            "assets"=>array(
                "path"=>"../../assets",
                "url"=>"assets",
            ),

            "dataSources"=>array(
                "substantiator"=>array(
                    "connectionString"=>"mysql:host=localhost;dbname=substantiator",
                    "username"=>"admin",
                    "password"=>"xxx",
                    "charset"=>"utf8"
                )
            )
        );
    }
    function setup()
    {
        $this->src('substantiator')
            ->query("SELECT * FROM employees")
            ->pipe($this->dataStore("employees"));
    }
}
proof that an old dog can learn new tricks
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.